Questions & Answers

Universal Control does not display options

0 votes
asked May 11 in Studio Series USB Interfaces by jerzypeter (160 points)

I'm using Presonus Studio 1824. Recently I upgrade Universal Control and it does not display the options to change the settings. I tried previous versions, and one of those worked. I rename file name of this setup from PreSonus_UniversalControl_v3_4_2_63992.exe to PreSonus_UniversalControl_v3_4_2_63992 THIS IS GOOD.exe to remind me that this version is OK.When I upgrade to the new version, the problem appeared again. I run setup from PreSonus_UniversalControl_v3_4_2_63992 THIS IS GOOD.exe and the problem still exists.Any help appreciated. I'm running Windows 10.

2 Answers

0 votes
answered May 12 by stanthompson2 (3,830 points)
I had this issue yesterday with on my Win10 machine and audiobox usb 96 after updating to ver 3.5.0 64605. It took 1 warm boot and 2 cold boots to display the settings for my device again
0 votes
answered May 12 by jerzypeter (160 points)
When uninstalled Ableton, Universal Control shows the settings!!!

Maybe this is a coincident?