Questions & Answers

Quantum 2626 not found - UC is empty

+1 vote
1,073 views
asked May 23, 2020 in Thunderbolt - Quantum by michielverhoeff (170 points)
Using MBP2019 i9 | Catalina:

Universal Control (latest version) has an empty black dashboard, so no green button with option for firmware update to quantum 2626. It seems that it can't find the Quantum 2626 device. (yes, I did signed in with the UC).

Also can't find Quantum 2626 in system preference --> sound-devices. Seems that it doesn't exist.

The red led is ON, Thunderbolt is connected.

Restarted the device AND the MBP many, many, many times. But still nothing seems to work.

This is not a good start with a brand new audio interface. I just want to make music, not solving hardware/software problems.

8 Answers

+1 vote
answered May 24, 2020 by anthonycervantez (390 points)
Any luck so far? Ive been having similar issues, but so far Ive just gotten radio silence on the issue. Thinking if I don't get any support in the next 2 days I really will have to return the 2626.
0 votes
answered May 25, 2020 by keithgoodwin1 (160 points)
Aye. Just bought a 26 x 32. UC tried to update the firmware twice and then said can’t connect and now UC can’t see it at all even though Windows can. I’m pretty ****** off about it. Brand new PC and interface. Useless. At this price point it’s ridiculous to buy something and then find others are having issues.
0 votes
answered May 26, 2020 by michielverhoeff (170 points)
Fortunately it works. It sounds stupid, but at the end I tried another TB3 cable and it finally works. Maybe the Quantum 2626 is very sensitive because the previous cable works well on other devices, so why not with this quantum 2626?

There are new issue's I already discovered (control panel), but will open a new discussion for that.

Thanks for the responses.
+1 vote
answered May 31, 2020 by robertburkhart1 (210 points)

I just received my Quantum 2626 and am also having this problem. I have tried reinstalling UC a few times but am not seeing the Quantum in UC ever. I have Logic Pro on this MacBook and also Pro Tools as I was using a Digi002 rack before this. Could either software be causing a coreaudio conflict/issue? At this point I don't think any combination of powering off, disconnecting, reinstalling UC works. I've tried them all. I've also tried multiple TB3 cables all brand new.

The MacBook Pro is a 2018 model running OSX Catalina. This is very frustrating on what should feel like Christmas morning!! ;-)

Can anyone help?

–2 votes
answered Jun 6, 2020 by kitwatson (610 points)

I just answered this elsewhere, but it makes sense to drop it here, too. The tl;dr answer... YES, the cable matters A LOT. 

I just rode a long support train with Sweetwater and PreSonus on this, and I'm going to give it you in a nutshell. I have had a Quantum 2626 for a couple of months now. Not only would it sporadically not show up in Universal Control, but at least once a day, it would randomly fall into fault mode and freeze up (froze up my iMac on several occasions, too). All the front panel input LEDs would suddenly glow solid red for 5 seconds, and then the unit would be effectively dead. Only a restart would bring it back. Ultimately, the problem was determined to be the cable. I was using the StarTech 2-meter passive 20 Gbit/sec cable that Sweetwater bundled with the Quantum. On the direction of PreSonus, I swapped that cable out for an Apple 0.8-meter active 40 Gbit/sec Thunderbolt 3 cable, and all my issues vanished. The cable, as it turns out, is an extremely critical component in the use of an interface like the Quantum 2626. So spend the 40 bucks, and get that cable.

https://www.apple.com/shop/product/MQ4H2AM/A/thunderbolt-3-usb%E2%80%91c-cable-08-m

It's not the cable you want, it's the cable you need.

0 votes
answered Mar 13 by robertomeola (200 points)

My quantum 2626  just fell into fault mode , all lights on. But i have original APPLE cable and adapter. It worked fine for a few days. I did not touch it, nor the cables. Now it does not work unless i restart the mac. So why don't they supply the cable themselves if the cable is so sensitive. I have APPLE cables what else do i need?

0 votes
answered May 21 by (330 points)
I have a ACER Swift 1 Windows 10 64 bit with USB- C (NOT THUNDERBOLT 3) and Quantum 2626 connected with Apple Thunderbolt 3 0.8m using Studio One 5. I’m upgrading from a Audio Box iTwo. Universal Control will not read my Quantum 2626. I’ve read every forum I can and I’ve almost tried all I can. Red light is solid and never seen it blue. What should I do? Any suggestions? Thanks!
+1 vote
answered May 22 by johnlangley (160 points)
I have an M1 Macbook. I bought the cable, did the install/uninstall...it doesn't work. I'm returning it.  It should just work like on the Presonus Youtube videos but it doesn't.  The blue light flashes but the UC is empty and Quantum is not recognized as a sound option.
...