Questions & Answers

New FP 8 Midi Mode in Logic Pro X

+1 vote
181 views
asked Apr 3, 2020 in FaderPort 8 by tomkeene (130 points)
just lost... love the new midi mode setup from greg but you just are not clear on LPX

a) does it only work with Catalina or more recent

b) provide specific instructions to get MidiMode set up in Logic Pro X

i do not understand why this is a continued battle

1 Answer

0 votes
answered Apr 26 by paulgreen10 (140 points)
In case anyone else is having difficulties with this it is possible to get the Faderport Midi Mode working with Logic Pro X (oh and I'm on Catalina).

Doing the following worked for me - your mileage may vary.

Firstly you need to check that 'Presonus FP8/16 Midi Mode' is visible in the list when assigning the Input and Output ports on the MCU Pro in 'Control Surface Setup'. If its not then you need to go to MIDI Studio and delete the 'Presonus FP8/16' entries (this is actually mentioned in the Presonus Youtube video about setting up Midi Mode so you can get more instruction there). You will then need to reset the Inputs and Outputs of the MCU Pro in 'Control Surface Setup' to 'Presonus FP8/16 Port 1' (your faderport probably won't be working in LPX at all now until you do this!)

Secondly you need to delete any control surfaces in 'Control Surface Setup' that have a '!' on them - I had some with the name ending in 'Light' (I cant remember the exact name).

Thirdly (im not sure if this step is actually required but it can be useful to check MIDI mode is working) you then need to go to 'Controller Assignments' and add a new Zone (I called it FP8 MidiMode but I don't think the name matters so call it what you want). Then click on the Learn Mode button and press a button or slide a fader on the faderport - it should be recognised on screen.

I was then able to use MIDI learn in Albion One to map a fader on the faderport to CC1 (modulation)
...