Page 1 of 2

Legato

PostPosted: Sun Sep 01, 2013 1:26 pm
by wcreed51
How can I get the first note under a slur to trigger the legato rule? I have these condition:

<if condition="under-slur" />
<if condition="slurred-attack" />

but it doesn't switch to the legato patch until the second note.

Re: Legato

PostPosted: Sun Sep 01, 2013 4:47 pm
by pcartwright
under-slur will trigger the effect for anything tied to or from a slur.
slurred-attack will only trigger the rule if the start of the pitch is part of the slur

With these conditions, I would not expect the first note of a slurred passage to trigger the rule.

If you want the first note of a slurred passage to trigger the legato effect, then try "slurred-release" by itself or to replace "slurred-attack".

Re: Legato

PostPosted: Mon Sep 02, 2013 9:11 am
by wcreed51
Both of those option result is correct playback of the legato, but if the note that precedes the legato passage is a staccato, there's an added note, almost like a grace note.

Re: Legato

PostPosted: Mon Sep 02, 2013 10:15 am
by pcartwright
Do you mind sharing your rules so I can take a deeper look?

Re: Legato

PostPosted: Mon Sep 02, 2013 10:37 am
by wcreed51
Thanks Peter

Re: Legato

PostPosted: Mon Sep 02, 2013 9:55 pm
by pcartwright
I'm not sure if this will solve the issue, but give the following rules file a shot and see what happens. All I did was remove the flag references (except for the first and last rule).

I don't suppose any of the CC values you are tweaking have some sort of repeat function?

VSL_Woodwinds.zip
(787 Bytes) Downloaded 247 times

Re: Legato

PostPosted: Mon Sep 02, 2013 9:59 pm
by pcartwright
If the first rule set doesn't work, try this one. I cut the staccato notes short (even though you clearly have a separate patch).

VSL_Woodwinds2.zip
(787 Bytes) Downloaded 264 times

Re: Legato

PostPosted: Tue Sep 03, 2013 1:49 pm
by wcreed51
Cutting the staccato notes short with <duration-change amount="0.80" /> does the trick. I added that to my original rules.

So now the performance is correct, but when I just play notes on the keyboard, it doesn't reset to the main patch. It selects the keyswitch from staccato, but doesn't send either of the cc settings.

Re: Legato

PostPosted: Mon Sep 23, 2013 10:19 am
by Admin
Notion has no way to identify the keyswitch through the Auditioning capabilities of using the keyboard to play notes in a VST. It will always resort to your main sound keyswitch when auditioning. I realize that this is a little frustrating, but you have to use a document with playback of actual articulations/techniques to be able to Audition your rules. There is a ticket submitted with this feature request and this is currently working as designed. It is certainly something that we need to work through.

-Admin

Re: Legato

PostPosted: Mon Sep 23, 2013 1:30 pm
by wcreed51
Right, that's what I'm saying. It's not returning to the main sound.