Attention:

Welcome to the old forum. While it is no longer updated, there is a wealth of information here that you may search and learn from.

To partake in the current forum discussion, please visit https://forums.presonus.com

"Echo Midi Input" using inconsistent channels

A Forum to Discuss NOTION

"Echo Midi Input" using inconsistent channels

Postby renochew » Fri Mar 29, 2013 12:23 pm

Hi all,

It seems there is a inconsistency in how "Echo Midi input" work in Notion.

If I select an external midi staff which is say, set to channel 2, although Notion did respect the setting and send the input from my keyboard through channel 2, but it seems that the cc message (e.g. expression) are still send through channel 1, or I am missing something?

Hope it make sense.

Thank you.
renochew
 
Posts: 10
Joined: Sun Jul 01, 2012 2:22 pm

Re: "Echo Midi Input" using inconsistent channels

Postby Admin » Mon Apr 01, 2013 12:18 pm

You have to change both the Sequencer Staff and the Instrument staff to output to the same channel.

1. Create a new Basic Staff staff.
2. Change the MIDI Output Channel by pressing Shift + I while the Staff is selected.
3. Open the Instrument Settings dialogue box.
4. Switch to the Notation tab.
5. Select the Sequencer Staff checkbox.

SequencerStaff CB.png
SequencerStaff CB.png (54.84 KiB) Viewed 4151 times


Record MIDI CC data for that channel on the Sequencer Staff that you have created.

Hope this helps,

-Admin
User avatar
Admin
Site Admin
 
Posts: 1006
Joined: Mon May 11, 2009 7:12 pm

Re: "Echo Midi Input" using inconsistent channels

Postby renochew » Thu Apr 04, 2013 6:51 pm

Hi, thanks for the reply. Unfortunately, I still can't make it work. Maybe I am not stating my problem clearly. My question is not really about recording or playback the score.

Say, I create an EXTERNAL MIDI Staff and route the output to MIDI PORT A / CHANNEL 4

Now, if I play my midi controller which is set at CHANNEL 1, notion will still output to CHANNEL 4 and I heard the correct sound from my external instrument (e.g. Kontakt in my DAW), but the problem came when I use the modwheel, notion will now use my midi controller channel (i.e. CHANNEL 1) and echo my midi performance to CHANNEL 1, which is what I mean inconsistent.

Of course I could change my controller to the correct channel but this make the workflow much slower if I need to change instrument very often. Ideally, when I select a staff, I should get consistent channel output, notion should ignore my controller channel no. (or at least there is an option to change the behavior)

That is actually how sibelius works btw, I really want to switch to notion entirely but these little thing make me hesitate somehow.

Thank you.
renochew
 
Posts: 10
Joined: Sun Jul 01, 2012 2:22 pm

Re: "Echo Midi Input" using inconsistent channels

Postby Admin » Tue Apr 09, 2013 12:18 pm

I have further investigated this problem. I see now what you are talking about. I have submitted a ticket for this issue. Thank you for the input.

-Admin
User avatar
Admin
Site Admin
 
Posts: 1006
Joined: Mon May 11, 2009 7:12 pm

Re: "Echo Midi Input" using inconsistent channels

Postby renochew » Thu Apr 11, 2013 5:39 pm

Thank you. Much appreciated.
renochew
 
Posts: 10
Joined: Sun Jul 01, 2012 2:22 pm

Re: "Echo Midi Input" using inconsistent channels

Postby dgriffee » Wed May 01, 2013 9:40 am

This is a long standing bug that has been known since way back in version 3, and has continued to be not fixed in version 4.
It has been elaborated upon and discussed and responded to by Admin before...
http://forum.notionmusic.com/viewtopic.php?f=24&t=3294
...and it is a real "bug" not just a matter of convention or implementation approach, it is a broken piece of old code buried somewhere in Notion that has been lingering since the very beginning.

The workaround to get playback cc data on the right channel is to select a staff and do SHIFT-I and manually select the desired midi channel and then click on the staff line to put an "instrument change" instruction in manually.

Nothing works for echo though, Notion always echos midi input cc data on channel 1 no matter what you do. Perhaps these issues are related to some obscure little shared module of code?
User avatar
dgriffee
 
Posts: 114
Joined: Sun Oct 04, 2009 10:09 pm

Re: "Echo Midi Input" using inconsistent channels

Postby Admin » Wed May 01, 2013 11:11 am

Actually, this is a Notion design implementation rather than a "bug". It simply needs to be rediscussed and we should determine how it should work going forward. That is the way that I wrote the ticket. I know the reasons it was designed this way and I understand the reasons for changing it. We will get to it.

-Admin
User avatar
Admin
Site Admin
 
Posts: 1006
Joined: Mon May 11, 2009 7:12 pm

Re: "Echo Midi Input" using inconsistent channels

Postby pcartwright » Wed May 01, 2013 5:06 pm

Admin wrote:I know the reasons it was designed this way and I understand the reasons for changing it.


Why was it designed this way?
pcartwright
 
Posts: 796
Joined: Sat Dec 05, 2009 2:47 pm


Return to NOTION

Who is online

Users browsing this forum: Google [Bot] and 3 guests