Attention:

Welcome to the old forum. While it is no longer updated, there is a wealth of information here that you may search and learn from.

To partake in the current forum discussion, please visit https://forums.presonus.com

Getting rid of the EWQL Missing Samples dialog

A Forum to Discuss NOTION

Getting rid of the EWQL Missing Samples dialog

Postby astinov » Sun Oct 04, 2009 2:11 pm

Hello EWQL users,

As some of you have noticed, when you bring up an EWQL instrument preset into your score, you may be presented with a missing samples dialog with three options Abort, Ignore and OK, that says "..Please locate the sample folder..." etc. The more experienced EWQL users have probably seen this before, this simply means you need to tell PLAY where your main EWQL installation path is.

The quick thing to do is to just click OK and browse to the folder that you installed EWQL in. You need to browse to the main folder, the one that contains both the Platinum Instruments and the Platinum Samples folders. The instrument should then load fine.

However, there is also a way to do this once for each preset and not have to worry about that dialog. Although it's a bit tedious, the good news is, you only have to do it once and you wont have to deal with the dialog again. I wanted to let you know how you can achieve this.

Here's how to get rid of the dialog:

1. Locate your EWQL PluginData folder. On Windows it is found in your Notion3 install directory under Support\PluginData\EWQL.
On Mac, you need to right-click your NOTION application and choose Show Package Contents, then Browse to Contents/Resources/PluginData/EWQL

2. You'll see a bunch of notion files, each named as an instrument. The first one should be called '01_Violins_I.notion'. Double click that file to open it in NOTION.

3. You'll see the missing samples dialog. Click OK and browse to the main EWQL installation folder where you have your instruments and samples folders

4. PLAY will then start loading the samples for the instrument preset. This WILL take some time, so be patient. As soon as PLAY is done and the notion score is all you see, SAVE the file and close it.

5. Repeat step 2 to step 4 for all notion files in the PluginData/EWQL folder.
(Hence why I said it's tedious...)

Once you've done it for all instruments then you MUST restart NOTION before trying to load the instrument presets. You have to restart the app for the changes to take effect, and from that point on you'll be able to enter in the EWQL instruments without the dialog warning.

Make sure you backup this newly edited version of your PluginData/EWQL folder (especially Mac users!) to a different place, because if you need to reinstall NOTION for whatever reason or you run an update, you don't want to loose all your changes, you can just use the folder you just created by pasting it in the right place.

With this, you should be able to configure your presets to not show this warning again.

Hope this helps,

Regards,

Lubo Astinov
astinov
 
Posts: 264
Joined: Tue Jun 09, 2009 1:40 pm

Re: Getting rid of the EWQL Missing Samples dialog

Postby Jerome Vonhögen » Sat Apr 03, 2010 5:13 pm

Hey Lubo,

Thanks for your workaround!

Before I found your post, I had figured out my own workaround for the problem (i.e. by choosing 'ignore' and then replacing the resulting 'empty' Play instruments by manually rebuilt & saved multi's of my own), but yours seems to really solve the problem so I would like to give it a try.

Before I do though, I would like to know whether saving the 'corrected' Notion files will save the relative path to the EWQLSO samples or the absolute path. Could you perhaps tell me how this gets saved? It would be nice to know beforehand if I will still be allowed to move my sample libs around after adjusting these Notion files.

By the way, I don't really understand how this bug could have been overlooked by the Beta team, since this is such an obvious bug and an annoying one as well. If they need any help with future releases, I will be available to test the Beta of Notion 4 anytime! ;)

- Jerome Vonhögen
Jerome Vonhögen
 
Posts: 4
Joined: Sat Apr 03, 2010 4:18 pm

Re: Getting rid of the EWQL Missing Samples dialog

Postby astinov » Tue Apr 06, 2010 9:26 am

Jerome Vonhögen wrote:Hey Lubo,

Thanks for your workaround!

Before I found your post, I had figured out my own workaround for the problem (i.e. by choosing 'ignore' and then replacing the resulting 'empty' Play instruments by manually rebuilt & saved multi's of my own), but yours seems to really solve the problem so I would like to give it a try.

Before I do though, I would like to know whether saving the 'corrected' Notion files will save the relative path to the EWQLSO samples or the absolute path. Could you perhaps tell me how this gets saved? It would be nice to know beforehand if I will still be allowed to move my sample libs around after adjusting these Notion files.

By the way, I don't really understand how this bug could have been overlooked by the Beta team, since this is such an obvious bug and an annoying one as well. If they need any help with future releases, I will be available to test the Beta of Notion 4 anytime! ;)

- Jerome Vonhögen


Hi Jerome,

Well, actually this is not technically our "bug" although believe me, I would like to not see it. What is happening is it has to do with how PLAY saves the location of the library and its paths once a project is saved. It has nothing to do with NOTION. You can actually recreate this behavior on different systems with different hosts. Long story short, it has to do with how PLAY saves the plugin information within a host.

Lubo Astinov
astinov
 
Posts: 264
Joined: Tue Jun 09, 2009 1:40 pm

Re: Getting rid of the EWQL Missing Samples dialog

Postby Jerome Vonhögen » Tue Apr 06, 2010 10:41 pm

Hi Lubo,

It would be very helpful if you could elaborate a little more. I'm a Beta tester for Play and Play Pro, and I'd like to investigate this issue. Could you please tell me what build of Play you have used for your tests? Did you test Play x64 (Win XP 64/Vista/Win 7) through jBridge as well? (I'm asking this, since that combination seems to work fine for the EWQLSO section presets, apart from the sample location issue of course.)

There are some things regarding the N3 presets that I don't really understand (yet). If I load up some section presets in N3, and then ignore the missing samples notification(s), Play will still show the instruments of the appropriate multis without any sample buffer being loaded into RAM. If I then save those multis within the Play plugin itself, I can successfully 'reload' them by simply using the "Replace All" option. Play won't ask for any sample data at all and all missing samples will load correctly. So, if Play correctly loads these multis within the plugin of the host, why would Notion 3 then be unable to tell the plugin to correctly load those multis within a project? (Or maybe N3 tells the Play plugin to load the instruments one by one, despite the fact that they share a Play instance in the case of section presets?)

Play stores several different paths in the registry (in Windows, that is), including the location of the last saved instruments, the location of the library after installation, paths to favorites, recently loaded instruments, etc. Does N3 use any of these paths for it's presets at all?

One more thing (just to be sure I understand): you wrote "it has to do with how PLAY saves the location of the library and its paths once a project is saved". I was wondering if you meant to say "when a project is saved". Frankly, I'm a bit confused about this, since I was under the impression that the N3 presets were fixed and therefore wouldn't depend on the project data itself. Maybe you could clear this up for me?

Thanks a lot for your time!

- Jerome Vonhögen
Jerome Vonhögen
 
Posts: 4
Joined: Sat Apr 03, 2010 4:18 pm

Re: Getting rid of the EWQL Missing Samples dialog

Postby achambily » Mon Dec 20, 2010 10:10 am

wouldn't be more simple to have a preference edit box where you can enter the right path ?!
(or, better, to detect it par code ?)
Notion, Cubase 7, EWQLSO Gold, VSL SE
Win7 x64, I7 Dell studio laptop, 8GB RAM
M-Audio FTP
M-Audio KeyStudio 25
Clavinova CLP 811
Sennheiser e840
Sennheiser HD280 Pro
Yamaha HS50M

http://chambily.com/
http://soundcloud.com/axel-casadesus/sets
achambily
 
Posts: 199
Joined: Sat Dec 18, 2010 12:25 pm


Return to NOTION

Who is online

Users browsing this forum: No registered users and 13 guests